Back to overview
Downtime
Major distruption
Oct 28 at 09:47pm CEST
Affected services
Website
Resolved
Oct 28 at 09:49pm CEST
We have identified the root cause of the issue and implemented a fix.
Affected services
Website
Created
Oct 28 at 09:47pm CEST
We are aware of an ongoing issue and are investigating.
Affected services
Website