Back to overview
Downtime
Service disruption
Oct 2, 2024 at 9:58pm UTC
Affected services
Website
Portal
API
Resolved
Oct 2, 2024 at 11:35pm UTC
We have deployed a fix. Users should be able to access the services.
Affected services
Updated
Oct 2, 2024 at 10:10pm UTC
We have identified the root cause of the issue and are working on a fix.
Affected services
Created
Oct 2, 2024 at 9:58pm UTC
All services are currently unavailable, we are investigating the issue.
Affected services